Announcement

Collapse
No announcement yet.

hell n back

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • hell n back

    Organised to go to the beach with some mates today, they came over had a look at the bike, bike was warming up a good 5mins before they came over.

    Heading down brady st towards the powis st entry/exit and bike stalls at lights started back up gave it some gas off again, get down pass lake monger and near the caltex passed the IGA and caltex and can feel bike dieing on me... get onto john sanders dr and the bike dies on me quickly pull over remember that they went to get petrol and i told them i will meet them there wait on the side of the rode for them for a good 10mins and they never came no credit cant call em... while i was waiting i was trying to get it started again it was starting but soon as i pull in clutch and change to first gear while clutch is still engaged bike dies... so i start pushing it towards the caltex(glendalough, herdsman area) on the corner.

    keep trying to start it, starts but soon as i put it in first gear dies still. pissed off i just start pushing it home clip helmet to backpack and start pushing it from the caltex towards to Powis st exit/entry sweating like a pig i get round the corner on brady st heading up the hill towards main st.

    I build up some energy and start running the bike up the hill get about half way up and my fkn bag breaks and my helmet comes off and starts rolling down the hill quickly put bike on stand and run n grab it i really could cry at this stage.. put helmet on head and push it to the top of the hill get to my st(tasman) at the very top of the hill and push it home.

    spotted a ckick on a maron zzr looking concerned but understand its pointless stopping when your about to jump on the freeway.

    now im home i turn the ignition on and nothing turns on.. lights, indicator etc.

    got home mates rang they took scarb beach rd to the beach they just came now thought i had crashed

    :'(



  • #2
    [checking calendar] nope not Friday 13th. Bummer dude, hope it's not too serious and you get back mobile again soon.

    Comment


    • #3
      +1 whs...

      Cheers and be safe
      Norm
      Its a Tour not a Race - Just don't get in my way when I'm Touring.

      OzVFR.net MGP Tipping Mews News

      Comment


      • #4
        Thats bad luck ay.......Feel your pain

        Comment


        • #5
          bikes running now used jumpers from car to get it going seems to be idling ok alot of smoke. is vortex 95 unleaded preimum?? :S or is that vortex 98 :S


          Comment


          • #6
            Ouch.....thats a bad series of events for anyone. You're better than me though, I reckon I'd have lost the plot by that point lol.

            Sounds like your battery isn't charging.
            A cynic is a man who, when he smells flowers, looks around for a coffin.

            Dear god, it's some weird bastardized three wheeled two person go-kart.

            Comment


            • #7
              Hell and back?
              I feel empathy for your episode but it's stories like this that make it great to own a bike and be a part of this community. Laugh about it.

              Try getting hit by a car, that's hell and back.

              Comment


              • #8
                true i was pretty funny i can image all the people driving past being like what the f*ck is he doing.. haha


                Comment


                • #9
                  Agreed with Boxx - it may have sucked at the time but will be something to laugh about in the future and you won't forget it in a hurry. Back in the day my RS-250 died on me at the top of kalamunda hill, luckily i live at the bottom haha, i rode it down in neutral in the full racer crouch.

                  Hope you revive your bike okay

                  Comment


                  • #10
                    i think i may have put the wrong fuel in(vortex 95 instead of 98).. its runs but wen i attemp to take off and i release the clutch it like wants to stall :S fkn werid


                    Comment


                    • #11
                      Sounds like the battery to me.

                      I find with my RGV unless I'm riding it almost daily it needs to go on charge every month or two to keep it fresh. When the volts are down mine runs rough and feels like its alternating between running on 1 or 2 cylinders and won’t rev smoothly and just gets worse till it stalls and dies on me.

                      Also try upping the revs a little when you tap it into 1st if you clutch drags a bit (mine will stall if I tap into first when cold at idle) and I've also found out if your clutch drags a little and you try and start it in gear with the clutch in you just end up getting hot, pissed off and the battery will go flat on you … Having a bike that is a pain to find neutral and has a neutral indicator that doesn’t work all adds to the fun as well

                      I hope you get yours sorted

                      Comment


                      • #12
                        Originally posted by frazcat View Post
                        i think i may have put the wrong fuel in(vortex 95 instead of 98).. its runs but wen i attemp to take off and i release the clutch it like wants to stall :S fkn werid
                        The RGV manual on fuel .... "Gasoline used should be graded 85-95 octane or higher"

                        I seriously doubt the quality of the fuel is your problem, charge your battery and then see how it runs (I'd expect it to be a bit rough at the start)

                        Comment


                        • #13
                          thanks for the info! it starting ok now after charging it from my car but it seems to be still having the same problem wen i take off even wen giving it alot or a little revs :S


                          Comment


                          • #14
                            95 or 98 makes no difference unless your over 13:1 compression ratio. When i was reading it before it sounded like your stand inhibit switch was the issue.

                            Idles ok, clutch in ok, in gear stops.
                            Atlas Performance, dyna pumps, " your name goes here"

                            Comment


                            • #15
                              Originally posted by frazcat View Post
                              thanks for the info! it starting ok now after charging it from my car but it seems to be still having the same problem wen i take off even wen giving it alot or a little revs :S
                              Charging it from your car?? Or do you mean jump starting it from your car? I've jumped mine when flat to ride home and it ran like shit, had to rev the hell out of it just to crawl away from the lights. If you haven’t got one already get yourself a battery charger from somewhere like supercheap and give it a proper charge

                              Comment

                              Working...
                              X