Announcement

Collapse
No announcement yet.

Oil light on, not oil level. 03 zx12r

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oil light on, not oil level. 03 zx12r

    oil light is on, oil pump sounds like it is alive, oil is fine and at a normal level.

    but oil light wont turn off.



    bike rides fine.


    !?

  • #2
    Does your bike have a seperate oil pump (that your hearing)? I wouldnt have thought so??

    Check the Kawasaki forums if you have no joy here - will be a oil pressure, or oil level switch. Not sure on that model.

    Could just be a faulty switch that needs replacing.
    Increasing my carbon footprint - one 500 @ a time...

    Comment


    • #3
      The oil light is a pressure switch, not a level switch (like the one in your fuel tank).
      I'd be checking the switch first, and making sure it's not something simple like a loose wire, then the actual switch itself, and after that, check the oil pump.

      edit: My bad, I assumed all oil warning lights were pressure related
      FTP

      Comment


      • #4
        The switch is located just forward of the alternator cover. Will be a single blue and red wire and is only secured with a philips head screw behind the rubber boot. I would be starting there, then checking the wire for continuity.

        The ZX12 doesnt carry a lot of oil, so if the pressure is down you will damage number 3 or 4 bearing in quick time. I got some cranks and cases in my shed to prove that. If in doubt dont ride it.

        Comment


        • #5
          Originally posted by aussiezx12 View Post
          If in doubt dont ride it.
          ^only know it was riding fine as i got down the road, realised the light was on and went straight back home.

          will give that a shot tomorrow.
          cheers for help kids.

          Comment


          • #6
            update: fairings off..
            poked around a bit, all connections were fine.
            put everything back together.

            oil light off.

            2 hours later, took it for a ride.. oil light still off.

            weird.

            Comment


            • #7
              Originally posted by Maxo View Post
              update: fairings off..
              poked around a bit, all connections were fine.
              put everything back together.

              oil light off.

              2 hours later, took it for a ride.. oil light still off.

              weird.
              Let us know if it happens again. Poking around the connections may have fixed a dodgy one. Glad its all ok and on the road though.

              Comment


              • #8
                Originally posted by Maxo View Post
                2 hours later, took it for a ride.. oil light still off.

                weird.
                Thats those pesky Kawasaki engineers keepin' ya on your toes
                Increasing my carbon footprint - one 500 @ a time...

                Comment

                Working...
                X