Announcement

Collapse
No announcement yet.

No tail Light

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No tail Light

    Hey guys,

    I have a 2006 Aprilia RS125 that's tail light doesn't work.
    Cop pulled me over last night and pointed it out to me. bloke was friendly and let me drive a few hundred meters to get home but just warned me.
    Anyways, my brake light, indicators etc. all work. the three fuses that i have look fine. Does anyone know of a 4th fuse or something some where? Is it meant to have a tail light? haha dumb questions but i can't figure this out.

    Any help is appreciated. Cheers.

  • #2
    it's global , dude.
    " Imagination is the seed of life..."

    Comment


    • #3
      Pulled the globe out yet and checked to see if both filaments are still intact?

      Older bikes with basic globes have dual filaments, one is tail one is brake;

      Trying to think of a wise and sincere signature quote, but the only words that leap to mind are, "TITTY SPRINKLES"

      Comment


      • #4
        It's Italian. That's the problem!

        Comment


        • #5
          It's either a loose connection to the tail light or a blown filament in the dual filament globe, as TurboR1 suggests.
          Click Link for My Bikes:

          Aprilia RS250
          1985 GSXR750 "Slabbie"

          Comment


          • #6
            So was it the globe? Or do we need to dig deeper?
            Trying to think of a wise and sincere signature quote, but the only words that leap to mind are, "TITTY SPRINKLES"

            Comment


            • #7
              Sorry about the slow reply. this is all sorted. Was just the globe. I didn't know about the dual filament thing.
              Cheers for the help

              Originally posted by TurboR1 View Post
              So was it the globe? Or do we need to dig deeper?

              Comment

              Working...
              X