Announcement

Collapse
No announcement yet.

Bloddy Bike Shop

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bloddy Bike Shop

    Well I just feel the need to vent out about a bike shop in Perth that’s causing me some serious anger the past 2 weeks. So let me start from the beginning, recently I took my bike into a “reputable” bike shop in Perth to have my carby re-jetted and tuned as it had a slight flat spot from 4 to 6k. I called this bike shop and booked in my bike with no issues and all, 2 days later I’m there picking up my bike to take it home and every thing seems fine.

    So on my way from the said bike shop my eclipse (led rev meter) stops working all together, no biggie there might be a shorted wire or something and I’ll get around to fixing it later. Bike runs fine this afternoon but the flat spot is still there now between 8 – 10k. This in it’s self was rather annoying as I paid them my hard earned cash (and quite a bit for what they did) and my bike was still not running correctly, ok I can deal with this and I’ll just see how it goes.

    Next day I head out to start my bike to head off to work and it’s running like a pig on 3 cyls whilst cold. Ok now I’m really starting to think this re-jet was not the best idea I ever had so I deal with it get to work and not worry about it. It comes to the end of my day and I jump on the bike to head home and once again running on 3cyls but this time ALL the way home.

    Ok so it’s got to the point were this is a little beyond a joke so I decide to call the shop the next day and ask them to have another look at it. I call the shop about my bike but the guy I was dealing with was sick, Ok fair enough I’ll give me a brake and decide to call the next day to see if he is in. I do this for the next 2 days but he is still sick and it’s getting close to the weekend. At this point the bike performance is getting worse so I park the bike up at home and decide to take the cage instead for the next couple of days.

    So it comes to Monday and I have to head off to my class for the day and my car is stuck in the garage behind one of my house mates cars (he has the only set of keys on him), no big deal I’ll ride the bike as is and just deal with it, so I go to start the bike and now it wont even fire!! Bikes turning over fine but not starting.

    So completely fed up with this I call the bike shop again and the guy I was dealing with is currently out of the office.. I call twice and he was either on the phone or busy. Finaly later in the day I get a hold of the guy and he says that they are going to need to have another look at the bike (NFS) So I organize for them to pick up the bike from my house on Wednesday as they can fit it in Thursday to have a look at it YAY I can look forward to riding again.

    Wednesday comes along and they pick up my bike not a problem can’t wait to get it back. Thursday comes along and they don’t call at all about the bike, Friday I’m busy working on the suspension on my car and forget about the bike altogether as I’ll just keep using the cage. Friday goes all by and still no call from the shop, so I call the shop today and get a hold of the guy I was dealing with he said they have been busy for the last few days and haven’t had a chance to look at my bike and will do TODAY!

    Now this is a little beyond a joke I’m not at all f#$kn happy at the moment!!!!

    Sorry about the long rant of a post I’m just really un-happy with the service of this shop. And need to vent this out some where
    RAM MOTOSPORT ZX10 RR#191

  • #2
    fuck! it wasnt' mculloch suzuki was it????? i have been having the EXACT same problems with them in the past two weeks (rant to be posted soon)
    at least you have your car as a back up..

    you should post which shop when you get your bike back..

    Comment


    • #3
      Not good....almost as bad as the guy who serviced my bike on Friday...private joke!

      Methinks it's time to name and shame.

      Steve
      Originally posted by Viper
      I'm probably fucking something up.
      FOREVER RIDING WITH "DAVO" - FarRider #1

      http://forum.fjr13.org/index.php
      Administrator

      Comment


      • #4
        I'm not going to name them in the thread but if any one is interested a quick pm and i'll let you know.. as always this is just my opnion on the shop it's self and it "may" differ on a case to case basis.. though from what I've heard it is pretty common
        RAM MOTOSPORT ZX10 RR#191

        Comment


        • #5
          Just name them, word of mouth and all that biz

          Comment


          • #6
            there wasn't a loose plug cap or something was there?
            thinking that could maybe mess with the shift light and obviously cause a misfire
            I'll email tony (eclipse) and ask if he has any ideas on the shift light
            No amount of genius can overcome a preoccupation to detail.



            Comment


            • #7
              Nah no loose plug caps or anything like that, I pulled the plugs after it wouldnt start to check they hadnt flouled up, but all was fine... I peronaly think the non starting is something to do with the timing as it was blowing flames out the exaust when it fuled up enough... but yeah guess I'll see soon enough
              RAM MOTOSPORT ZX10 RR#191

              Comment


              • #8
                mate that is a joke... if there was a flat spot still in it when u picked it up, i would have just turned around and gone straight back and asked wtf they have actually done to fix the thing... and if they even test drove it to see if it was running ok..

                by all means give them a mouth full when u speak to them, and dont hand over any more money what so ever.. id even be speaking to who ever owns the shop..

                mate send us a pm, id like to know who they are, cheers.

                Comment


                • #9
                  Thanks sathid

                  Man... they've definitely given you the screw around!

                  First of all, regarding the shift light I'd be reeally surprised if it was actually damaged. I've only ever had one die, and that was from a bike with a blown reg/rec putting out 18+ volts that destroyed the instrument tacho, , blew both headlights, battery boiled, the he told me the shift indicator showed the overvoltage warning for over 20 minutes before stopping, and shortly after the CDI permanently died completely!! Talk about self destruct

                  The tacho line that drives the shift indicator is seperate from the actual wires that fire the ignition coils. So it would be a seperate problem. If the tacho still works, then I'd check that the shift indicator is still plugged in. they may have unplugged it thinking it might be causing them problems. Also check that just turning ignition on gives you some lights, or at least pressing some buttons. If not, check the ground and ignition wires are still connected. I'm happy to run through any of this with you if you need.

                  As for the cylinder firing wrong...

                  If you get the bike back and it still has problems, there are some things you could do to try and resolve the problem. You can work out which cylinder is not firing by 'really carefully' seeing which one is colder. They have obviously removed the carbs to play with the jets/needles and most likely the spark plugs (or at least should of). I'd suggest checking the high voltage lead is properly connected to the plug - easy done. Next I'd pull the plug and make sure its not fouled and check the colour. If the power drops off as the RPM builds, I'd tighten the rubber boot clamp, the one between the engine block to the carbs, as it might be leaking air (easy tightened).

                  It may however be the carbs are leaking, the jet isn't adjusted properly, or the carb bowls seal might be letting air come through. Either way, I'd expect it should take them no more than 3 hours to solve. I'd call them up and mention it would only take a good mechanic a couple of hours to fix, so whats the holdup ..and if you get it back with the same problem you'll be expecting your money back in full.

                  Comment


                  • #10
                    Well it's past 7pm now and I didn't get a call this arvo at all which means I'll be chasing it up again tomorrow...

                    Eclipze : Cheers for that, hopfuly I wont have to even think about fixing it as "they" should be doing that for me.

                    If not I'll take your advise and get the ole multimeter out and do some troubleshooting.

                    I'm fairly sure the unit it's self wont be deal and is just lacking power (no lights come on at all) so looking like a loose wire or something.

                    Thanks every one for the support and comments, also all PM's in regards to the shop have been sent off
                    RAM MOTOSPORT ZX10 RR#191

                    Comment


                    • #11
                      next time give derek ball a call. he'll comes to you...great service!
                      got him to do all the work on my bike.

                      hope you get your bike back in a working cond.

                      ps. could you also pm me the name of the bike shop.

                      Comment

                      Working...
                      X